Mazda CX‌-30 Forum banner

1 - 17 of 17 Posts

·
Registered
2021 CX-30 GT AWD - Machine Grey Metallic
Joined
·
135 Posts
Also does it sometimes in very heavy rains. The times when you need it working the most (poor visibility) is often the time it fails due to weather. I've not had these safety systems on other cars so I don't know if it's specific to Mazda, but maybe a small heating element or something on that front logo would have helped?
 

·
Registered
Mazda CX30 SEL LUX
Joined
·
88 Posts
Discussion Starter · #3 ·
Also does it sometimes in very heavy rains. The times when you need it working the most (poor visibility) is often the time it fails due to weather. I've not had these safety systems on other cars so I don't know if it's specific to Mazda, but maybe a small heating element or something on that front logo would have helped?
The time you want your safety features and it disables lol ! wasn't Heavy snow like you get in Canada etc but found it interesting how the system reacted. Good job we do not get alot of snow here lol, but i like the idea of a heated element (y)

I have driven in far worse snow, but i just wanted to go out and play ;)
 

·
Registered
Joined
·
9 Posts
I see that message all the time even when its summer, 90 degrees outside with a clean radar. It makes it so I can't use cruise control, which is really annoying.
 

·
Registered
Joined
·
124 Posts
... but maybe a small heating element or something on that front logo would have helped?
I was thinking the same thing. I received that error a few weeks ago on a cold but not-very-snowy day. When I stopped the car to see what was blocking it, it turned out to be a thin layer of ice that had formed over the logo. If that's all it takes to disable it maybe a small heating element could have been included. Sticking out of the front of the grill it's going to get water / snow / ice / slush / mud on it all the time. So far it's only failed once for me... but it's been a mild winter so far.
 

·
Registered
AWD 2020 GT CX-30 ceramic coated
Joined
·
698 Posts
Iv gotten Into the habbit of checking it on a regular basis to make sure it's clean and iv driven through a few snow storms with little issue and only is one if I forget to clean it off or am driving on the highway with salt slush from other vehicles covering it and that even flowing from a far distance as I hate getting stone chips.
 

·
Registered
Mazda CX30 SEL LUX
Joined
·
88 Posts
Discussion Starter · #7 ·
Iv gotten Into the habbit of checking it on a regular basis to make sure it's clean and iv driven through a few snow storms with little issue and only is one if I forget to clean it off or am driving on the highway with salt slush from other vehicles covering it and that even flowing from a far distance as I hate getting stone chips.
with you on keeping distance with stone chips !
 

·
Registered
Mazda CX30 SEL LUX
Joined
·
88 Posts
Discussion Starter · #8 ·
I was thinking the same thing. I received that error a few weeks ago on a cold but not-very-snowy day. When I stopped the car to see what was blocking it, it turned out to be a thin layer of ice that had formed over the logo. If that's all it takes to disable it maybe a small heating element could have been included. Sticking out of the front of the grill it's going to get water / snow / ice / slush / mud on it all the time. So far it's only failed once for me... but it's been a mild winter so far.
luckily enough we don't get much in the way of snow, well i say luckily enough... I'm 43 and turn into a big kid when it does snow ;):LOL::ROFLMAO:
 

·
Registered
Mazda CX30 GT Sport Tech Skyactive X Auto Deep Crystal Blue
Joined
·
64 Posts
I have had the second photo warning come on during totally dry weather but with sun shining to the front of the vehicle. I goes off after a while but can be intermittent for some time.
 

·
Registered
AWD 2020 GT CX-30 ceramic coated
Joined
·
698 Posts
I have had the second photo warning come on during totally dry weather but with sun shining to the front of the vehicle. I goes off after a while but can be intermittent for some time.
Hmm so Interesting.. so back in the summer mine and as glitchy and doing what you said plus randomly telling me to BREAK! With nobody in front and I documented it and showed the pictures to my dealership and the service manager emailed them off to Mazda technical which advised him that it's a defective sensor.. and so he ordered a new one and it's since been installed.. free months later it's working better then it was before and no issues. Just thought I would let you know that it was replaced under warranty.
 

·
Registered
Mazda CX30 GT Sport Tech Skyactive X Auto Deep Crystal Blue
Joined
·
64 Posts
Hmm so Interesting.. so back in the summer mine and as glitchy and doing what you said plus randomly telling me to BREAK! With nobody in front and I documented it and showed the pictures to my dealership and the service manager emailed them off to Mazda technical which advised him that it's a defective sensor.. and so he ordered a new one and it's since been installed.. free months later it's working better then it was before and no issues. Just thought I would let you know that it was replaced under warranty.
Thanks for your comment, I also get the BRAKE message from time to time accompanied by a loud warning noise. I will mention it to my dealer when the first service is due at the end of January.
 

·
Registered
AWD 2020 GT CX-30 ceramic coated
Joined
·
698 Posts
Thanks for your comment, I also get the BRAKE message from time to time accompanied by a loud warning noise. I will mention it to my dealer when the first service is due at the end of January.
My dealership said they had the same issues on the 2019 Mazda 3s and it was a instant warranty claim.. and Mazda approved the warranty claim on my CX 30 with no issues and so I would voucher for a sensor replacement.. take pics of the occurrence and the sensor condition and have the dealership submit that to Mazda for warranty claims approval. Shouldn't be a problem.
 

·
Registered
Joined
·
28 Posts
Hmm so Interesting.. so back in the summer mine and as glitchy and doing what you said plus randomly telling me to BREAK! With nobody in front and I documented it and showed the pictures to my dealership and the service manager emailed them off to Mazda technical which advised him that it's a defective sensor.. and so he ordered a new one and it's since been installed.. free months later it's working better then it was before and no issues. Just thought I would let you know that it was replaced under warranty.
This is really interesting. I've had the same issue as the OP this past week, but as commented, we dont exactly get loads of snow so not a massive issue. However, the being told to brake all the time with nothing in front of you, and even once it doing a full on emergency stop for no reason which I had absolutely no control over, is a problem. My electronic diagnostics have been sent off to Mazda Europe, and I'm just waiting on an answer for this together with frequent power loss/braking. Interesting to see your sensor point, which I will mention to them. Thanks
 

·
Registered
Mazda CX30 SEL LUX
Joined
·
88 Posts
Discussion Starter · #14 ·
Hmm so Interesting.. so back in the summer mine and as glitchy and doing what you said plus randomly telling me to BREAK! With nobody in front and I documented it and showed the pictures to my dealership and the service manager emailed them off to Mazda technical which advised him that it's a defective sensor.. and so he ordered a new one and it's since been installed.. free months later it's working better then it was before and no issues. Just thought I would let you know that it was replaced under warranty.
Getting the same too, it did it yesterday when there was nothing even near me !
 

·
Administrator
2020 CX-30 Skyactiv-X MHEV GT Sport Tech
Joined
·
432 Posts
Thanks for your comment, I also get the BRAKE message from time to time accompanied by a loud warning noise. I will mention it to my dealer when the first service is due at the end of January.
I've noticed when you approach a chicane (traffic calming measure used in the UK) with another car waiting for you to go through, the CX-30 responds with BRAKE and a noise. I just tell the car to shut up. I kind of expect the car to detect this and anticipate it.

It tells me the system is working.

I've not noticed this happening in other circumstances.
 

·
Registered
Joined
·
28 Posts
I've noticed when you approach a chicane (traffic calming measure used in the UK) with another car waiting for you to go through, the CX-30 responds with BRAKE and a noise. I just tell the car to shut up. I kind of expect the car to detect this and anticipate it.

It tells me the system is working.

I've not noticed this happening in other circumstances.
My car tells me BRAKE fairly regularly. There are certain roads near me that have a lot of parked cars that it seems to have a noticable aversion to. Bizarrely though, I live on a cul-de-sac which has a narrow entrance road, often awash with parked cars, but it's never done it here. Doesnt seem.any logic to it. I also tell it to shut up! 😄
 

·
Administrator
2020 CX-30 Skyactiv-X MHEV GT Sport Tech
Joined
·
432 Posts
Doesnt seem.any logic to it. I also tell it to shut up! 😄
It does shows we're aware of the car - and of the surroundings. If it yells 'out of context', I'd be more likely to do what the car says.
 
1 - 17 of 17 Posts
Top