Mazda CX‌-30 Forum banner

1 - 20 of 37 Posts

·
Registered
AWD GT CX-30 ceramic coated
Joined
·
437 Posts
Discussion Starter #1
So last couple of days iv been experiencing a random issue with a warning.
"front radar sensor obstructed which has temperately disabled mazda safety sense and please drive carefully"

So i get a random message like that that will suddenly happen when i go to start the vehicle if its been sitting for some time and disables all the safety features and radar cruse control of course and upon carefully inspecting the emblem sensor on the front gill mine is perfectly clean and no scratches at all and nothing blocking it at all.

then after a little while of highway speeds it seems to resolve it self and everything goes back to normal which is very intresting as iv changed nothing lol just drive at a fast speed 100 KM/h.

I called my dealership today as this is now #3 that this will randomly happen and for no obvious reason as i can understand this happening if it was winter with snow but lol not the case and so my service advisor at my dealer said that there is somebody else recently with another CX-30 experiencing the same issue so they want to take a look at it and try a couple things like reset the BCM as well as throw a ticket in with Mazda. This is a annoying issue as its hard to duplicate and is very random but at least it isn't just me with the issue.

Also i asked about the two recall campaigns with the Front calipers and fuel tank and my dealer is finally are aware of it and said i should be getting a letter in the mail soon and by that point they will have the parts in to do those recalls.
 

·
Registered
2020 Mazda CX-30 GT AWD - Soul Red Crystal
Joined
·
134 Posts
I got that error message 3 separate times back in June. It was really hot out, so I figured maybe it was because of the humidity. My radar sensor and emblem were perfectly clean. (Just washed car day before). The error corrected itself each time within maybe 5 minutes of driving.

It hasn’t happened since so I’ve just let it go with no questions asked.
 

·
Registered
AWD GT CX-30 ceramic coated
Joined
·
437 Posts
Discussion Starter #4
It happened to me once. I dismissed it as the car was facing the sun on a really hot day. Fixed itself and did not come back yet
My dealership said someone else too had the same issue and they want to look into it and for a fix as in their words it shouldn't happen unless a very very heavy rain or snow on it or a heavy snow fall driving through it . I am also waiting to get the letter on the mail for the two recalls as they said they applied to my vehicle when they ran my Vin so wait for that and then they will have the parts to do the recalls.
 

·
Registered
AWD GT CX-30 ceramic coated
Joined
·
437 Posts
Discussion Starter #5
I got that error message 3 separate times back in June. It was really hot out, so I figured maybe it was because of the humidity. My radar sensor and emblem were perfectly clean. (Just washed car day before). The error corrected itself each time within maybe 5 minutes of driving.

It hasn’t happened since so I’ve just let it go with no questions asked.
Yah so far it's been more frequently as of late so the dealership wants to have a look at it and put a ticket into Mazda as I'm not the only one who has reported this issue to them.
 

·
Registered
AWD GT CX-30 ceramic coated
Joined
·
437 Posts
Discussion Starter #6
And it did it this morning when I was leaving from work .. and its not hot out nor is there dew on it as it sat outside overnight 8 hrs ... It's a +10 C outside.. sure is a strange issue .. hope they can find a fix at my dealership.
 

·
Registered
2020 Mazda CX-30 GT AWD - Soul Red Crystal
Joined
·
134 Posts
And it did it this morning when I was leaving from work .. and its not hot out nor is there dew on it as it sat outside overnight 8 hrs ... It's a +10 C outside.. sure is a strange issue .. hope they can find a fix at my dealership.
Keep us posted if you find a fix or not.
 

·
Registered
AWD GT CX-30 ceramic coated
Joined
·
437 Posts
Discussion Starter #9
Lol again haha just woke up and meeting a friend for a run .. and it's been sitting for 7 hrs and so I decided to document everytime it happens incase Mazda Canada needs to be contacted..
698
699
 

·
Registered
Joined
·
47 Posts
I’ve done 4500 klms and it’s only happened to me on 3 occasions which was pretty heavy rain , it would only last for a few minutes then all good again , first time I thought wtf
 

·
Registered
CX30 GT SPORT. A Road cyclists who drives a CX30 on the odd occasion...
Joined
·
401 Posts
We had similar in our previous Mazda's, when the camera, up near the rear view mirror was used for the safety features..in winter and in cold conditions it condensate , causing it to stop working....I would of thought radar would be better in these conditions....we have had no issues so far..
 

·
Registered
AWD GT CX-30 ceramic coated
Joined
·
437 Posts
Discussion Starter #13
Lol now it's doing it every time I go and drive .. don't know why as everything is clean and clear.. but thx for the feed back guys and at least my dealership knows it's not just me and somebody else is having the same issues.
 

·
Registered
AWD GT CX-30 ceramic coated
Joined
·
437 Posts
Discussion Starter #15
Hmmm, can it be unplugged...
no because its a intermittent if you read my other posts in this thread.the issue its not just me having the issue another client at my dealership is also having the same issue ... it sometimes is perfectly fine and other times glitches out like that.
 

·
Registered
20 CX-30 AWD JBM Prem
Joined
·
183 Posts
no because its a intermittent if you read my other posts in this thread.the issue its not just me having the issue another client at my dealership is also having the same issue ... it sometimes is perfectly fine and other times glitches out like that.
I despise the MRCC. I would love to disable mine permanently.
 

·
Registered
20 CX-30 AWD JBM Prem
Joined
·
183 Posts
I like it .. but the sensor has to do more then just with that .. it's part of the emergency collision avoidance system.
If you could set the sensitivity and forget it, I would be on board. Defaulting at every restart is annoying.
The system encourages left lane campers.
 

·
Registered
Joined
·
1 Posts
I know someone who is having the same issue. They have been working with their Mazda dealer for a few weeks now. In her 1 hour highway commute, the radar cruise will disable 3 or more times during the commute, which means that her cruise control stops working.

Her dealer has been looking into this, and had ordered in a new sensor to see if that resolved the issue.
 

·
Registered
CX30 GT SPORT. A Road cyclists who drives a CX30 on the odd occasion...
Joined
·
401 Posts
Have you tried a Ctrl , alt delete... remove the negative battery terminal leave for a while and reconnect. Just to see if it needs a sensor reset?
 
1 - 20 of 37 Posts
Top