Mazda CX‌-30 Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
We recently had an issue with our gas pedal not responding. We were slowing down to enter a round about ,as we tried to accelerate the pedal was not responsive. We took it to the dealer, they had it for a week , drove it @ 50 miles and could not replicate the issue. No codes were thrown. Has anyone else had a similar issue? Did you finally get it resolved? Thanks in advance for any help.
 

·
Registered
22 CX 30 Turbo GT & 22 3 in Soul Red
Joined
·
240 Posts
Okay more info is needed. Did it engage back into drive or did it have to be towed?
As silly as it may sound did it inadvertently have neutral selected?
Were you getting any RPMs?
Your situation could be a bit frightening had you been attempting to cross a road with traffic.

On a side note to all that may read this, I know I am going to get flack for this too but the correct spelling is
PEDAL…..not petal, peddle….and

BRAKE….. not break.

Sorry but can’t help myself as a son of a former teacher.😉
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Ok more info....
It was pulled over to the side of the road and shut off. A short while later I restarted it and was able to drive it a short distance home. It has not replicated the issue since either with me or at the dealer.
It did not throw any codes
It was not in neutral
We had to coast to a safe spot to pull off the road
No RPMs, as the pedal was pushed it gave no response
And I agree completely this could have been a very serious situation had it been in a different setting. this is my daughters car and we want her to be safe.
Although I do understand the need to have the issue replicated by the service dept. I just wish they could or would do something to resolve this. Unfortunately I am not sure as to what.
Gauges were in the "normal" readings range ,90s outside temp, 35MPH zone , it had been driven @ 5 miles prior to the issue happening in light traffic
 

·
Registered
22 CX 30 Turbo GT & 22 3 in Soul Red
Joined
·
240 Posts
Bizarre!
The unfortunate part of this is with no codes, and unable to replicate the issue, how can it be resolved?
As a parent this has to be very unnerving and makes you wonder what the situation might be IF it happens again.
With all the electronic nannies in cars nowadays there are bound to be weird issues that pop up from time to time.
I wish I could give you some solid advice on how to deal with this to help you move on for peace of mind.
Not sure if it would help, but if you could contact a regional service manager and quiz him on the situation to see if there is any type of history of this happening? Without any published TSB’s for this it may be just a one off quirk.
Hope you can work this through.
Cheers,
Rick
 

·
Registered
Joined
·
6 Posts
Maybe not the same, but I noticed that I can't accelerate if I'm driving to close to the car in front of me. It was strange situation that I had a car to close in front of me, but gas pedal wasn't reacting. I was thinking that my car suddenly turned off..... very strange experience..... Later I found out it was safety feature, but don't remember if my car was breaking also.
 

·
Registered
22 CX 30 Turbo GT & 22 3 in Soul Red
Joined
·
240 Posts
Maybe not the same, but I noticed that I can't accelerate if I'm driving to close to the car in front of me. It was strange situation that I had a car to close in front of me, but gas pedal wasn't reacting. I was thinking that my car suddenly turned off..... very strange experience..... Later I found out it was safety feature, but don't remember if my car was breaking also.
Do you have adaptive cruise control and if so was it on?
 

·
Registered
2021 CX-30 eSkyactiv-X GT Plus
Joined
·
11 Posts
Happened to me too once. I was close behind another car, and I wanted to accelerate, and the gas pedal didn’t respond for maybe a second. As the gap widened between two cars, I was able to accelerate normally.

Also, once in the roundabout the car slammed on the brakes itself and turned on all for turn signals because, I guess, it computed that I would crash into the car in front of me. Luckily, no one rear ended me.

Don’t know what to think about all this features. I really like blind spot monitoring, but for other safety features I have mixed feelings. I guess they are irritating until they help you from crashing into something.
 

·
Registered
Joined
·
18 Posts
Just to confirm that I’m experiencing that behavior rather often when I’m nearing the car in front of me. If the car releases the brakes and I anticipate that it will accelerate the gas pedal doesn’t respond until sufficient gap is created. Feels terrible every time, as if the engine stalled.
 
1 - 12 of 12 Posts
Top