Mazda CX‌-30 Forum banner
1 - 18 of 18 Posts

·
Registered
2020 CX-30 GT, Machine Grey
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi Folks,
I have had a CX-30 GT for about 8 months now. Today I pushed the button in the car to open the liftgate and....nothing. Same with fob button. I can manually move it up and down but it won't close (i.e. won't latch). I checked the fuses and sure enough the one for the liftgate had blow. But here's the issue.....the manual (screen shot below) says the fuse should be a 25amp, but the one in the actual car is a 15amp (second image below....it's definitely blown...I just put it back in for the picture).
So wtf? Can someone with a power liftgate please check their car (panel is neat left footrest on driver side) and confirm that you also have a 15amp fuse there, and that your layout is the same as mine? Maybe a mistake was made in production but seems unlikely?? I've had zero issues until now, including a whole Canadian winter with snow and ice on the liftgate and it's worked perfectly. I don't want to put a 25amp in there if t's supposed to be a 15 (obviously dangerous), but I also don't want to replace it with another 15 if it's supposed to be a 25 (and of course among the extras they give you in the engine compartment fuse box, there are no 15s!). Thanks - really appreciate it.
1908


1909
 

·
Registered
2021 CX-30 GT AWD - Machine Grey Metallic
Joined
·
219 Posts
Also, it looks like you have a 25A spare sitting in slot F23, which is not used, while mine is empty. Very strange that it would come from the factory with the wrong fuse in there.
 

·
Registered
2020 CX-30 GS FWD, Snowflake White
Joined
·
1,521 Posts
I would double-check with your dealers service department to be safe. Can't help as I don't have that feature on my model.
 

·
Registered
2020 CX-30 GS FWD, Snowflake White
Joined
·
1,521 Posts
Thanks ArcticHound. Strange indeed. And the orientation of your 30amps are also different from mine (though don't know if that matters?).
is yours a 2020 model, his is a 2021 (fill out your drive info details)
 

·
Registered
2021 CX-30 GT AWD - Machine Grey Metallic
Joined
·
219 Posts
Thanks ArcticHound. Strange indeed. And the orientation of your 30amps are also different from mine (though don't know if that matters?).
I think like the other fuses they're completely reversible, so whomever installs them doesn't concern themselves with the neatness of having them all face a common direction.
 

·
Registered
2020 Mazda CX-30 GT AWD - Soul Red Crystal
Joined
·
162 Posts
Hi Folks,
I have had a CX-30 GT for about 8 months now. Today I pushed the button in the car to open the liftgate and....nothing. Same with fob button. I can manually move it up and down but it won't close (i.e. won't latch). I checked the fuses and sure enough the one for the liftgate had blow. But here's the issue.....the manual (screen shot below) says the fuse should be a 25amp, but the one in the actual car is a 15amp (second image below....it's definitely blown...I just put it back in for the picture).
So wtf? Can someone with a power liftgate please check their car (panel is neat left footrest on driver side) and confirm that you also have a 15amp fuse there, and that your layout is the same as mine? Maybe a mistake was made in production but seems unlikely?? I've had zero issues until now, including a whole Canadian winter with snow and ice on the liftgate and it's worked perfectly. I don't want to put a 25amp in there if t's supposed to be a 15 (obviously dangerous), but I also don't want to replace it with another 15 if it's supposed to be a 25 (and of course among the extras they give you in the engine compartment fuse box, there are no 15s!). Thanks - really appreciate it.
View attachment 1908

View attachment 1909
Take it into your dealer. There’s a liftgate recall anyway.


Recall:
4621B
Date:
2021-03-02
Status:
Incomplete
Details:
Recall:

2020 & 2021 CX-30 Power Liftgate May Partially Lower
Safety Risk:
2020 & 2021 CX-30 Power Liftgate May Partially Lower
Repair:
Your dealer will update the power liftgate control software, inspect the liftgate motors and, if needed, the motors will be replaced, free of charge
 

·
Administrator
2020 CX-30 Skyactiv-X MHEV GT Sport Tech
Joined
·
829 Posts
My 2020 GT has a 25A fuse in place.
Welcome to CX30Talk

You should consider posting an introduction here so we can welcome you properly. It is like starting a conversation by saying 'Hello'. If you're wondering what to say, take a look at other members introductions. Some are detailed, others are short. But remember, do not post about issues in the New Members area.

If you are new to forums, or the format of this forum, then read our introduction here.
 

·
Registered
2021 CX-30 Select AWD
Joined
·
109 Posts
It would have been bad if the system worked on a 15amp circuit and they stuck a 25amp fuse in there. Then instead of a fuse you would have needed to possibly changed the motor. At least they gave you an extra one and a correct on at that. Glad it was an easy fix and thanks for confirming the correct setting.
 

·
Administrator
2020 CX-30 Skyactiv-X MHEV GT Sport Tech
Joined
·
829 Posts
Marking thread as resolved as the correct size fuse has been determined - and indeed fitted.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top