Mazda CX‌-30 Forum banner

81 - 100 of 111 Posts

·
Registered
Joined
·
12 Posts
Edz2k20 - thanks to you for all the useful posts & screen shots. Thanks to you & all the other contributors I now have upgraded software & therefore the speed camera warnings!
It's taken me to-ing and fro-ing with the dealership since Sunday, but eventually, after sending them your screen shots last night, they came and collected it today did the update and returned it.
The service manager left me a voicemail this afternoon saying "you were right the software did needing upgrading from 45 to 47. Your research was spot on". Think I've taught them a thing or 2, as prior to my call they had no idea!
So a big thank you to everyone and to anyone who is thinking about doing it - go for it, if I can get the dealership to sort it, then anyone can! 😁
 

·
Registered
2020, CX-30 Sports Tech SkyActiv-X - Machine Grey
Joined
·
122 Posts
Fantastic result glad to have helped :)
 

·
Registered
Joined
·
5 Posts
Car went in for its 1k service earlier in the week and told them there was an update for which the service guy said he didn't know anything about but said he'll check. 2 hours later hurrah! Got the 10047 update and a call from Mazda Au today saying admitting there is an update. Warning settings aren't as informative as the old Mazda connect but better than nothing . Thanks for the info everyone
 

·
Registered
Mazda CX30 GT Sport Tech Skyactive X Auto
Joined
·
15 Posts
My dealer updated the Connect Firmware this morning to 1047, but I still do not have vocal warnings of speeding or speed cameras available,similar to my previous CX5 just the annoying noises when over the limit. I cannot see anything new to activate these warnings, where do you set them up? I have checked the Firmware version and can confirm it does show 1047. Any help would be appreciated.
 

·
Registered
2020, CX-30 Sports Tech SkyActiv-X - Machine Grey
Joined
·
122 Posts
My dealer updated the Connect Firmware this morning to 1047, but I still do not have vocal warnings of speeding or speed cameras available,similar to my previous CX5 just the annoying noises when over the limit. I cannot see anything new to activate these warnings, where do you set them up? I have checked the Firmware version and can confirm it does show 1047. Any help would be appreciated.
If you go into the navigation screen then select the options the warning options should be there:

806
807
 

·
Registered
2020, CX-30 Sports Tech SkyActiv-X - Machine Grey
Joined
·
122 Posts
If not you may want to get the toolbox software from the Mazda site and update your maps (you get 5 years subscription free on a new car) be aware the backup and update process does take quite some time even on a fast connection.

Mazda Toolbox
 

·
Registered
Mazda CX30 GT Sport Tech Skyactive X Auto
Joined
·
15 Posts
Thank you for replying, I have followed your guide but all I see in Warning Settings is "Visual and Audio" and in Speed Camera "Always on or when speeding " comments. Ticking the boxes of both just gets the horrible chimes when over the speed limit and no recognition of speed cameras at all. I have updated maps June 2020 latest version.

Whilst at the dealers today they also updated a new revision to the CPU which apparently was released last week with updates to the problems many owners (like myself) with battery draining problems. One of the items I have now noticed was the message "Ignition is not switched off" when leaving the vehicle, this has now gone and I was advised it has also corrected a problem leaving the USB ports continually live.

Sadly, contacting dealers with fixing problems with speed cameras is a waste of time, as usual individual posters on forums always appear to know more about such things than the dealer.
 

·
Registered
2020, CX-30 Sports Tech SkyActiv-X - Machine Grey
Joined
·
122 Posts
I do know the speed camera data has to be present may be worth updating the map files in the toolbox software.

Can you check what version you have installed now is it 10047?
 

·
Registered
Mazda CX30 GT Sport Tech Skyactive X Auto
Joined
·
15 Posts
I do know the speed camera data has to be present may be worth updating the map files in the toolbox software.

Can you check what version you have installed now is it 10047?
Thanks again, yes the software does show 1047 and I have just tried to update the maps in Mazda Toolbox which states I have the latest version June 2020. I have followed some earlier comments ie: removing the neg. battery lead, reset everything on the Connect to Factory Settings, re-applied my settings, just test drove again increased speed to 45 in a 40 limit and all I got was the original non stop default warning sound, no vocals at all. Maybe the latest CPU upgrade has changed something.
 

·
Registered
2020, CX-30 Sports Tech SkyActiv-X - Machine Grey
Joined
·
122 Posts
How odd

Can you take some phone pics on the menu options in your navigation settings?
 

·
Registered
CX30 GT SPORT. A Road cyclists who drives a CX30 on the odd occasion...
Joined
·
333 Posts
Sounds like you have set the speed limit alert...
 

·
Registered
Mazda CX30 GT Sport Tech Skyactive X Auto
Joined
·
15 Posts
Yes I will do tomorrow when there is more light available.
Sorry for the delay, I have played around all day with different settings, still only getting the standard warning noise, no spoken words at all, but I notice the speed camera image is shown in the navigation screen wilst driving, but no warnings.
821
 

·
Registered
2020, CX-30 Sports Tech SkyActiv-X - Machine Grey
Joined
·
122 Posts
Mmm... May have missed it but is your map data up to date?
 

·
Registered
Joined
·
12 Posts
This looks just like mine does post update, and the lady speaks to me to warn me of speed cameras, so not sure why yours isnt working...... sorry

Sorry for the delay, I have played around all day with different settings, still only getting the standard warning noise, no spoken words at all, but I notice the speed camera image is shown in the navigation screen wilst driving, but no warnings. View attachment 821
 

·
Registered
Mazda CX30 GT Sport Tech Skyactive X Auto
Joined
·
15 Posts
Could someone help how to reboot the Connect System as the Back-Mute-Nav or Back-Nav-Mute buttons do not appear to do anything. My previous CX5 was easy to reboot the system by using one of these combinations. Many thanks
 

·
Registered
CX30 GT SPORT. A Road cyclists who drives a CX30 on the odd occasion...
Joined
·
333 Posts
Try removing battery negative for a few minutes..this will reboot everything...

it is in the thread somewhere, if there is no voice when hitting the voice command button, disconnect the battery for a ew swconds..
 

·
Registered
2020, CX-30 Sports Tech SkyActiv-X - Machine Grey
Joined
·
122 Posts
Was going to say this sounds like an incorrectly applied or taken update. If you press the voice command button on the steering wheel do you get the voice command prompt if not, Steve is right reboot it with the main battery terminal or go back to the dealer.
 

·
Registered
Mazda CX30 GT Sport Tech Skyactive X Auto
Joined
·
15 Posts
Thanks everyone for your input, I can confirm the voice command works ok and I have disconnected the battery for 5 minutes but still no warnings. Sadly, I have no confidence in my dealer as they could not discover why my battery was continually dying until I forced something from them via Mazda UK.
They claimed the 1047 or even 1045 Infotainment updates did not exist until I showed them some print outs from this forum and even then they said it did not apply to this model only the Mazda 3 ( I assumed they were the same car in many ways) Speaking to them today they claimed the CX30 does not give out speeding or camera warnings. I suspect they have not updated the firmware correctly, but getting them to admit it will be impossible

This dealer handed the car over to me with almost 46PSI in all the tyres, no water in the screen washer bottle and.the engine cover unlocked, flapping around and making noises. My first service will be elsewhere.

They have ruined what should have been a great experience of a new car, especially after my previous CX5 not having a single fault in the 39 months I drove it.
 
81 - 100 of 111 Posts
Top