Mazda CX‌-30 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all,
My CX30 seems to have a whining sound coming from the transmission at low speeds. If I roll the window down and am close to a bank or barrier, I hear a soft whining sound that changes with engine rpm. Doesn't happen when at idle in park, just when in gear and running around 25mph. I also noticed that the computer loves to lug the engine when climbing steep hills at low speeds, I'm surprised the car doesn't stall. I also noticed that it gets confused when letting off when climbing and hill then getting back on the gas, there seems to be a delay in me pushing the pedal and the gearbox actually transmitting power. All in all, I'm kind of disappointed in the transmission programming for this car. It feels like it's trying to replicate some of the attributes of a dual clutch (used to drive a VW with a DSG, and even it was smoother), and not the good ones. It's too easy to confuse at low speeds.
 

·
Registered
Joined
·
13 Posts
Yep and people talk about American "junk". This is my first Japanese car and while it's fun to drive there is nothing special about the fit and finish or the drivetrain.
 

·
Registered
Joined
·
3 Posts
Hi all,
My CX30 seems to have a whining sound coming from the transmission at low speeds. If I roll the window down and am close to a bank or barrier, I hear a soft whining sound that changes with engine rpm. Doesn't happen when at idle in park, just when in gear and running around 25mph. I also noticed that the computer loves to lug the engine when climbing steep hills at low speeds, I'm surprised the car doesn't stall. I also noticed that it gets confused when letting off when climbing and hill then getting back on the gas, there seems to be a delay in me pushing the pedal and the gearbox actually transmitting power. All in all, I'm kind of disappointed in the transmission programming for this car. It feels like it's trying to replicate some of the attributes of a dual clutch (used to drive a VW with a DSG, and even it was smoother), and not the good ones. It's too easy to confuse at low speeds.
Seems like you're having a similar problem to mine. I started a thread a while back:

Whining Noise From Automatic Transaxle

They had to replace my whole transmission to fix the whining noise. Best guess of the issue is from that old TSB in my post... The transaxle bearing must be off and/or damaged during manufacturing... This issue seems to have been lingering in Mazda's transmissions for years now... I'm shocked they never managed to permanently fix it... I never heard of this problem with any other modern day manufacturer... Incredible.
 

·
Registered
2020 AWD Select Machine Gray Metallic Mobil 1 0w20
Joined
·
167 Posts
If you google the problem, a lot of Mazda 3 owners report the same issue and they claim it is normal.
 

·
Registered
2020 AWD Select Machine Gray Metallic Mobil 1 0w20
Joined
·
167 Posts
I think it's normal.
 

·
Registered
2020 Mazda CX30 Soul Red Select AWD
Joined
·
103 Posts
You can just barely hear it from inside the car when going slow, and from the outside it sounds like the electric motor whine from a hybrid, that's the best way I can describe it.
I am going to guess you have AWD. Because my AWD cx-30 does as you describe and has for 11,000 miles. It is the drive shaft or rear diff (Normal). My Mother's FWD cx-30 is silent driveline wise...
 
1 - 9 of 9 Posts
Top